Unbabel - Problems logging into Customer Portal – Incident details
All systems operational
About This Page
Unbabel's status page is where you can get updates on how our systems are doing.
If there are interruptions to service, we will post a message here.
Problems logging into Customer Portal
Resolved
Degraded performance
Started 11 days agoLasted about 15 hours
Affected
Unbabel Portal
Degraded performance from 7:20 PM to 10:24 AM
Updates
Resolved
Resolved
This incident has been resolved.
Investigating
Investigating
Some users are describing problems logging into the Portal, with an error message reading "Failed to retrieve your Portal". We are currently investigating this incident.