Unbabel - Customer Support Response delayed – Incident details

All systems operational


About This Page


Unbabel's status page is where you can get updates on how our systems are doing.
If there are interruptions to service, we will post a message here.

Customer Support Response delayed

Resolved
Degraded performance
Started 3 days agoLasted about 20 hours

Affected

Unbabel

Degraded performance from 12:43 PM to 8:25 AM

Updates
  • Resolved
    Resolved

    Communications are back to normal.

  • Monitoring
    Monitoring

    We're back online as the power is progressively back across the affected countries and the CH team will get back to every query as soon as possible. Thank you for bearing with us.

  • Identified
    Identified

    Our Customer Happiness Team might be delayed responding to your queries due to the power outage affecting some European countries.