All systems operational


About This Page


Unbabel's status page is where you can get updates on how our systems are doing.
If there are interruptions to service, we will post a message here.

Completed
Access Management Services Maintenance

Status
Resolved after about 1 hour
Started
March 22, 2022 at 9:00 PM
Completed
March 25, 2022 at 1:40 AM
Affects
Unbabel Portal
Unbabel Chat
Unbabel Interface Chat
Unbabel E-mail
Unbabel Interface Tickets
  • Completed
    March 22, 2022 at 9:52 PM

    Maintenance has been completed successfully.

  • In progress
    March 22, 2022 at 9:08 PM

    Maintenance is now in progress.

  • Planned
    March 22, 2022 at 9:00 PM

    In order to meet the highest reliability and scalability standards, our team will be upgrading the access management services so you will not be able to access the Unbabel Interface product between 9:00 pm and 9:40 pm UTC. The Customer Happiness Team will remain available to help with any questions and concerns you might have.